aboutsummaryrefslogtreecommitdiff
path: root/gtk/configure.ac
diff options
context:
space:
mode:
authorTakamichi Horikawa <takamichiho@gmail.com>2017-03-30 23:31:39 +0000
committerTakamichi Horikawa <takamichiho@gmail.com>2017-03-30 23:31:39 +0000
commitf47eba7d7d4c6a1d9501e027b63bbab04bb7d417 (patch)
treec6d8ebf4f84b76e9d32d4998d28a69d36fddd4a9 /gtk/configure.ac
parenta86bb48b9f3acb081afa92e5efc50d0192c4f68c (diff)
add NEON optimization
Diffstat (limited to 'gtk/configure.ac')
-rw-r--r--gtk/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/gtk/configure.ac b/gtk/configure.ac
index 8e13a34..2727888 100644
--- a/gtk/configure.ac
+++ b/gtk/configure.ac
@@ -2,10 +2,17 @@ AC_INIT([fmplayer], [0.1.0])
AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects])
AM_SILENT_RULES([yes])
AC_PROG_CC_C99
+AM_PROG_AS
dnl AM_PATH_SDL2([2.0.5])
PKG_CHECK_MODULES([PORTAUDIO], [portaudio-2.0])
PKG_CHECK_MODULES([GTK3], [gtk+-3.0 cairo])
+AC_ARG_ENABLE([neon], AS_HELP_STRING([--enable-neon], [Enable NEON optimized functions for SSG sinc filtering and fmdsp palette lookup. Tested on Cortex-A53 (Raspberry PI 3)]))
+AM_CONDITIONAL([ENABLE_NEON], [test "x$enable_neon" = "xyes"])
+AS_IF([test "x$enable_neon" = "xyes"], [
+ AC_DEFINE([ENABLE_NEON])
+])
+
AC_CONFIG_FILES([Makefile])
AC_OUTPUT