aboutsummaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 0247644..3524f15 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -42,7 +42,6 @@ endif
fmplayer_SOURCES=main.c \
toneview.c \
- oscilloview.c \
../tonedata/tonedata.c \
../common/fmplayer_file.c \
../common/fmplayer_file_gio.c \
@@ -50,3 +49,9 @@ fmplayer_SOURCES=main.c \
$(FMDRIVER_SRC) \
$(FMDSP_SRC)
+if ENABLE_OPENGL
+fmplayer_SOURCES+=oscilloview-gl.c
+fmplayer_LDADD+=-lGL
+else
+fmplayer_SOURCES+=oscilloview.c
+endif