aboutsummaryrefslogtreecommitdiff
path: root/gtk/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gtk/configure.ac')
-rw-r--r--gtk/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/gtk/configure.ac b/gtk/configure.ac
index 2727888..f49bd74 100644
--- a/gtk/configure.ac
+++ b/gtk/configure.ac
@@ -2,6 +2,8 @@ AC_INIT([fmplayer], [0.1.0])
AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects])
AM_SILENT_RULES([yes])
AC_PROG_CC_C99
+AC_PROG_RANLIB
+AM_PROG_AR
AM_PROG_AS
dnl AM_PATH_SDL2([2.0.5])
@@ -14,5 +16,11 @@ AS_IF([test "x$enable_neon" = "xyes"], [
AC_DEFINE([ENABLE_NEON])
])
+AC_CHECK_HEADER([emmintrin.h], [emmintrin_found=yes])
+AM_CONDITIONAL([ENABLE_SSE], [test "x$emmintrin_found" = "xyes"])
+AS_IF([test "x$emmintrin_found" = "xyes"], [
+ AC_DEFINE([ENABLE_SSE])
+])
+
AC_CONFIG_FILES([Makefile])
AC_OUTPUT